I suggest you ...

Don't make autocomplete write things you didn't ask for. VS 11 beta

When I write
x = pow(a,b);
in C++ (VS 11 beta), the "smart" intellisense feature turns this into
x = pow(abs,BENIGN_RACE_BEGIN);
without me actually pressing any other keys. You have to actively press the Esc key after every keystroke to say no the the "smart" suggestions of what you want to write. This violates all usability principles. It is very useful that the intellisense feature shows a list of proposed identifiers, but it should never write anything for you unless you actively point to the name in the proposal list you want.

It took me a lot of experimentation to find out that I should go into tools -> options -> Text Editor -> C/C++ -> Advanced -> IntelliSense -> Member List Commit Characters and delete everything in the list of characters there to solve the problem. This "commit characters" feature is useless and should at least be off by default.

Another usability problem: Sometimes the editor responds too slowly to keystrokes so that you can't see what you are writing or whether the cursor is in the place you want to write. I suspect it might be the intellisense feature that delays the writing of characters on the screen. Or maybe it is something else? The update of the screen text in the editor when pressing a key should of course have higher priority than everything else.

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    A FogA Fog shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    3 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • NilsNils commented  ·   ·  Flag as inappropriate

        This auto commit stuff, which requires you to actively press esc, really made me angry. I mean I know what I type.

      • Oliver KleinOliver Klein commented  ·   ·  Flag as inappropriate

        Setting the filter mode (from "Fuzzy") to "None" did the trick for me. Personally I think it's really annoying, but I'm sure there are tons of programmers out there who think differently.

      Feedback and Knowledge Base