I suggest you ...

Add support for TLS 1.2 in Visual Studio 2015 Enterprise Web Performance Tester

Our security policies are mandating use of TLS 1.2. When attempting to script and playback a web performance test I received an SSL error. Only by adding a coded plug-in supplied by MSDN support was able to get it to work. Going forward support for TLS 1.2 should be included "out of the box"

39 votes
Vote
Sign in
(thinking…)
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
Hans Wertz shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

8 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • kumar commented  ·   ·  Flag as inappropriate

    Hi Phillip & GezaSoos,

    I have added these entries on my Reg edit file. But still i am facing the "Request failed: An existing connection was forcibly closed by the remote host".

  • Phillip Pegues commented  ·   ·  Flag as inappropriate

    This was EXACTLY the fix I'd spent almost a week trying to do..and with no need for a VS test plug-in. Thanks! For me, I was testing SharePoint 2016 sites, of course using HTTPS, and I'd been having similar redirect errors to everyone else. This got me going.

  • Jared Shields commented  ·   ·  Flag as inappropriate

    The registry fix provided by @GezaSoos solved the problem for me! it also fixed Excel being unable to connect when TLS 1.2 was enabled.

  • Ian Hodgetts commented  ·   ·  Flag as inappropriate

    Thanks for this! I was having issues with previously working webtests failing in VS2017 ("Request failed: An existing connection was forcibly closed by the remote host"). Despite my projects using .NET Framework 4.7.1 the tests were failing until I added the two registry entries.

  • Babu04 commented  ·   ·  Flag as inappropriate

    We are using TFS 2015 Update 4. We can't connect to TFS from client versions MTM 2015, VS 2012, GitBash and Excel Plugin aren't working with TLS 1.2 only. We got it working when enabled TLS 1.0 & TLS 1.2. Enabling TLS 1.2 & TLS 1.1 aren't doing anything.

  • Geza Soos commented  ·   ·  Flag as inappropriate

    Try this on the client:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
    "SchUseStrongCrypto"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]
    "SchUseStrongCrypto"=dword:00000001

  • Jeff Blankenbiller commented  ·   ·  Flag as inappropriate

    We have TFS 2015 Update 3 and we have disabled TLS 1.0 on the server.

    We can't connect from MTM 2015.

    Please add support for TLS 1.1 and TLS 1.2 to MTM.

Feedback and Knowledge Base