I suggest you ...

Edit and Continue: Allow Edit and Continue x64 under local IIS

This suggestion is migrated to Developer Community. Please use below link to view the current status.
https://developercommunity.visualstudio.com/content/idea/351308/edit-and-continue-allow-edit-and-continue-x64-unde.html
Edit and Continue x64 is an outstanding addition to Visual Studio 2013. Unfortunately, I tend to use the full IIS server on my local machine for debugging, but the Edit and Continue option becomes disabled as soon as I change from "IIS Express" to "local IIS".

The error message states that changes are not allowed "when the debugger has been attached to an already running process", which I assume is because the IIS Application Pool (running as w3wp) is already running when debugging is started..

How can this be fixed?

Ideally, this should be fixed by allowing the debugger to run Edit and Continue on an already running process (which would also solve the issue of IIS Express shutting down when Edit and Continue is enabled).

Alternatively, when using Edit and Continue on local IIS (which should be off by default), the debugger should cycle the worker process and attach to it when starting itself up (then recycle the worker process again to disconnect). This option should include significant warnings that this will happen so users are not surprised (which is why I recommend this option be disabled by default).

178 votes
Vote
Sign in
(thinking…)
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
saluce65 shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

2 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • Nomad commented  ·   ·  Flag as inappropriate

    @Ondrej Vrsan
    Thank you. Your fix worked.

    I opened applicationHost.config at the specified node and added the aforementioned node under the app pool I was using.

  • Ondrej Vrsan commented  ·   ·  Flag as inappropriate

    In IIS 10.0 (Win 10)

    In Administrator command line run
    C:\Windows\System32\inetsrv>appcmd set apppool "DefaultAppPool" /+environmentVariables.add[@start,name='COMPLUS_ForceEnC',value='1']

    (replace DefaultAppPool with app pool name you use)

    This will add tag
    <environmentVariables>
    <add name="COMPLUS_ForceEnC" value="1" />
    </environmentVariables>
    into C:\Windows\System32\inetsrv\config\applicationHost.config for your app pool, so the app pool process always run in Edit and Continue mode.

Feedback and Knowledge Base