I suggest you ...

SSDT Tabular model edits should only update on change

In the tabular model editor, there's an annoying lag whenever you do the following actions in the grid view:
1. Right click, insert a new column - doing this should immediately allow you to edit the name or formula for the column (or both)
2. Renaming a column that has no formula associated with it
3. Clicking on an existing column to copy a formula, and then selecting a different column without making changes.

These minor (paper cut) annoyances make the model editor slow to work with.

4 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Joshka shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Kay Unkroth commented  ·   ·  Flag as inappropriate

    Joshka, Tabular models up to the 1103 compat level were based on the UDM metadata stack, which was originally designed for multi-dimensional models. As a consequence, Tabular metadata operations didn't perform well because internally the AS engine had to perform quite some work to persist tabular metadata as if it was multi-dimensional metadata. The metadata stack has been redesigned from scratch for the 1200 compat level, introduced with SQL Server 2016. Now with a true Tabular metadata stack in the engine, you get to enjoy a snappy user experience in SSDT. My recommendation: Upgrade your models to 1200.

Feedback and Knowledge Base