How can we improve Microsoft Visual Studio for Mac?

TFS Version Control

This suggestion is migrated to Developer Community. Please use below link to view the current status.
https://developercommunity.visualstudio.com/content/idea/351809/tfs-version-control.html
Add support for TFS as a version control provider.

1,764 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    We have a new update ready for you now – version 0.4.3 was release just yesterday.

    If you already have it installed, open the Visual Studio > Extensions… > Updates tab to update to the latest release. If you’re new to the extension, follow the steps in https://docs.microsoft.com/en-us/visualstudio/mac/tf-version-control.

    Please let us know how well it’s working for you. Please report issues using the Help > Report a Problem menu.

    Also, please follow along with this issue going forward on our Developer Community site: https://developercommunity.visualstudio.com/content/idea/351809/tfs-version-control.html

    Thanks!
    Jordan, Program Manager, Microsoft Visual Studio for Mac

    405 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Jordan Weber-Flink commented  ·   ·  Flag as inappropriate

        Got the latest version. The computer name in the config file was empty, once I edited that I was able to create a workspace connecting to On-Premise TFS server. Able to download repository (slow), check out, check in. Major issues affecting me right now: auto-checkout is sketchy, doesn't always work. Example: packages.config, csproj files must be manually checked out. Additionally, no way to check in all pending changes for solution. I have 3 projects in my solution, as well as some linked files from a common directory. Requires 4 checkins to get all changes committed.

        Pleased to have something. Good work so far - keep going!

      • Anonymous commented  ·   ·  Flag as inappropriate

        Getting an error TF400367

        Cannot create the workspace. Please, try again.
        Server was unable to process request. ---> TF400367: The request could not be performed due to a host type mismatch. Please check any connection information and verify the information is correct. The request was executed against a Deployment, Application

      • Paulo Munoz commented  ·   ·  Flag as inappropriate

        I get this error message: "An error has occurred mapping the selected paths. Please try again later."

      • Maxim commented  ·   ·  Flag as inappropriate

        As somebody on July 11th, 2018 at 12:35 already said, we also cannot make a commit on files (up to this, we cant checkout the files just by start writing in it ...) and get the 401 unauthorized error. Here is the stacktrace:

        System.Net.WebException: The remote server returned an error: (401) Unauthorized.
        at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00059] in /Users/builder/jenkins/workspace/build-package-osx-mono/2017-12/external/bockbuild/builds/mono-x64/mcs/class/System/System.Net/HttpWebRequest.cs:1033
        at System.Net.HttpWebRequest.GetResponse () [0x0000e] in /Users/builder/jenkins/workspace/build-package-osx-mono/2017-12/external/bockbuild/builds/mono-x64/mcs/class/System/System.Net/HttpWebRequest.cs:1045
        at MonoDevelop.VersionControl.TFS.Services.UploadService.UploadPart (System.String fileName, System.String workspaceName, System.String workspaceOwner, System.Int32 fileSize, System.String fileHash, System.String range, System.String contentType, System.Byte[] bytes, System.Int32 copyBytes) [0x0011b] in <44b11cbea5eb491eaa1e670a935d715d>:0
        at MonoDevelop.VersionControl.TFS.Services.UploadService.UploadFile (System.String workspaceName, System.String workspaceOwner, MonoDevelop.VersionControl.TFS.Models.CommitItem item) [0x0005c] in <44b11cbea5eb491eaa1e670a935d715d>:0
        at MonoDevelop.VersionControl.TFS.Services.RepositoryService.UploadFile (MonoDevelop.VersionControl.TFS.Models.WorkspaceData workspaceData, MonoDevelop.VersionControl.TFS.Models.CommitItem commitItem) [0x00012] in <44b11cbea5eb491eaa1e670a935d715d>:0
        at MonoDevelop.VersionControl.TFS.Models.ProjectCollection.UploadFile (MonoDevelop.VersionControl.TFS.Models.WorkspaceData workspaceData, MonoDevelop.VersionControl.TFS.Models.CommitItem commitItem) [0x0000b] in <44b11cbea5eb491eaa1e670a935d715d>:0
        at MonoDevelop.VersionControl.TFS.Services.WorkspaceService.CheckIn (MonoDevelop.VersionControl.TFS.Models.CommitItem[] changes, System.String comment, System.Collections.Generic.Dictionary`2[TKey,TValue] workItems) [0x00058] in <44b11cbea5eb491eaa1e670a935d715d>:0
        at MonoDevelop.VersionControl.TFS.TeamFoundationServerRepository.OnCommit (MonoDevelop.VersionControl.ChangeSet changeSet, MonoDevelop.Core.ProgressMonitor monitor) [0x000af] in <44b11cbea5eb491eaa1e670a935d715d>:0
        at MonoDevelop.VersionControl.Repository.Commit (MonoDevelop.VersionControl.ChangeSet changeSet, MonoDevelop.Core.ProgressMonitor monitor) [0x00019] in /Users/builder/data/lanes/5965/6ae73188/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl/MonoDevelop.VersionControl/Repository.cs:563
        at MonoDevelop.VersionControl.CommitCommand+CommitWorker.Run () [0x00079] in /Users/builder/data/lanes/5965/6ae73188/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl/MonoDevelop.VersionControl/CommitCommand.cs:70
        at MonoDevelop.VersionControl.VersionControlTask.<BackgroundWorker>b__13_0 () [0x00000] in /Users/builder/data/lanes/5965/6ae73188/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl/MonoDevelop.VersionControl/VersionControlTask.cs:52
        at System.Threading.Tasks.Task.InnerInvoke () [0x0000f] in /Users/builder/jenkins/workspace/build-package-osx-mono/2017-12/external/bockbuild/builds/mono-x64/mcs/class/referencesource/mscorlib/system/threading/Tasks/Task.cs:2886
        at System.Threading.Tasks.Task.Execute () [0x00010] in /Users/builder/jenkins/workspace/build-package-osx-mono/2017-12/external/bockbuild/builds/mono-x64/mcs/class/referencesource/mscorlib/system/threading/Tasks/Task.cs:2509

        Hope you will fix it soon ... :(

      • Zachary Hunt commented  ·   ·  Flag as inappropriate

        I still can't get this setup. I try to create a new workspace, it prompts me to fill out two fields (name and file path), I fill them out and it says "some mandatory fields are missing"

      • Anon E. Moose commented  ·   ·  Flag as inappropriate

        I'm blocked from adding a local Workspace due to my full Computer Name being too long.

        "TF10156: The computer name [long computer name] contains unsupported characters, is empty, or too long."

        Any chance you can up the supported character count?

      • Anonymous commented  ·   ·  Flag as inappropriate

        Can sign in to TFS, see the projects, map to a workspace and make edits to files. I cannot commit them though. I get version control operation failed (401) unauthorized.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Still not working for me. Using TFS and my credentials I get the error message "Access is denied due to invalid credentials."

      • vvergani commented  ·   ·  Flag as inappropriate

        I can connect to my TFS server.
        I have three collections containing different projects.
        After connecting, I see the three collections, but inside every collection I see the projects of the first collection. I try to explain: I have collection1 with projectA and ProjectB. Then I have collection2 with projectC and projectD.

        When I browse collection1, I see projectA and projectB hosted in collection1. Browsing collection2, I see the same project (projectA and projectB) and I cannot see projectC and projectD

      • Ben Funk commented  ·   ·  Flag as inappropriate

        If by "creating workspaces against these environments" you mean that nothing actually downloads, then yes, there are still issues. Hopefully it'll get solved soon. I'm eager to use it.

      • Andreas Aronsen Nesheim commented  ·   ·  Flag as inappropriate

        Follow-up on my previous comment: I was able to add the missing write permissions to the files using the "chmod" command. Now the project retrieved using this extension builds.

      • Andreas Aronsen Nesheim commented  ·   ·  Flag as inappropriate

        I am now able to connect to our on-premise TFS server and was able to pull down the code! I was able to by using the following URL format: "http://mysourcecodeurl:8080/tfs". I also had to add the domain, don't know if this applies for everyone.
        I did experience a build error though, but I am not sure if this is related to this extension. The error message: "The "ACTool" task failed unexpectedly." Turns out that all the files have a write lock on them. Tried to unlock the files with some commands, but nothing worked.

      • chetan oswal commented  ·   ·  Flag as inappropriate

        Trying to connect on-premise TFS server, keep getting Unable to Authenticate error. Tried all combinations of domain & username but no luck.

      • Roger commented  ·   ·  Flag as inappropriate

        I'm able to authenticate against our on-premises TFS, the project list of a TFVC collection does not list any project on Source Control Explorer; and the collections that only support GIT the IDE say it's not under source control.

      • Ben Funk commented  ·   ·  Flag as inappropriate

        With our on-premise TFS instance, I just keep getting "unable to authenticate".

        Should domain and user be domain\user or just user in the user and domain in the domain? I've tried both and neither works.

      • Nigel Kirkby commented  ·   ·  Flag as inappropriate

        Hi, I still cannot connect to our source control repository using the v0.3 of this extension. It just keeps coming back to the 'Where is your project hosted? screen, which has nothing in the list of repositories. In Visual Studio running on Windows 10 on a parallels VM on the very same MacBook Pro, the exact same credentials work absolutely fine.

      • Francesco Aiello commented  ·   ·  Flag as inappropriate

        After entering credentials it just infinitely loads. What is the solution? I'm using TFS Server on visualstudio.com.

      ← Previous 1 3 4 5 20 21

      Feedback and Knowledge Base